Compatibility List

Device Compatibility List

REM-Fit App Compatibility List

iPhone: Requires iOS 8.2 or above



Android: Requires Android 4.3 'Jelly Bean' or above. Also requires BLE support.